PHP: Hypertext Preprocessor, also called PHP, is a famous general-purpose server-side programming language, which is used to develop dynamic websites with interactive components like discussion forums, e-learning portals or social networking websites. In contrast with static HTML sites, a PHP-driven site can show different content to each user under the exact same URL. Because of the fact that PHP-based web applications can be managed via a Control Panel tool, which you can sign into from any web browser, you will not have to possess any web design experience or prior experience whatsoever to administer a PHP website. The fact that 100s of millions of websites around the globe are built with PHP is an indication of the popularity and the ease of use of the language. You only have to confirm if the web server on which your website is hosted supports the very same version of PHP as the one that you used whilst setting up the website.

PHP 4 and PHP 5 Support in Cloud Website Hosting

In case you buy a cloud website hosting plan from our company, you’ll never need to speculate on whether your websites are compatible with the web hosting environment, since different versions of PHP are activated on our servers for your convenience. The Hepsia hosting Control Panel will permit you to pick PHP 4, 5.2, 5.3, 5.4 or 5.5 with only one single click and in case you would like to change the current version, the new settings will take effect straight away. Thus, many years of work on websites built with an older PHP version will not be in vain. Our hosting platform will even allow you to use a different PHP version for each domain hosted in your account, which suggests that you can use newer and older scripts simultaneously. Most hosting providers on the marketplace support one, sometimes two PHP versions. In contrast with them, we think that you should be the one to choose the version that your own websites will be using.

PHP 4 and PHP 5 Support in Semi-dedicated Servers

In case you have a website created in an earlier PHP version and you’ve put in time and effort into developing it, plugging safety gaps and embedding page content, you’ll need to find a web hosting service that can support it, since almost all hosting vendors these days support only the most recent version of PHP and abandon the previous versions. We, however, have decided to allow you to choose the version that your very own sites require. Our semi-dedicated plans support multiple versions of PHP 5 as well as PHP 4, which implies that you will be able to use both older and newer scripts without losing any custom tweaks or frittering away time and efforts struggling to make your sites compatible with the web hosting environment. The current version can be changed through the Hepsia hosting Control Panel and such an update will apply to the whole semi-dedicated account, but you’ll also be able to specify a different version for each individual website that you host in your account using an .htaccess file.